martes, 17 de agosto de 2010

Reparar problema video Skype en Ubuntu

Desde que actualicé a de ubuntu 9.10 a ubuntu 10.04, el único programa que me mantuvo con problemas fue Skype, del cual cuando iniciaba video llamada, no podía ver la imagen de mi amigo que emitía, ni la mía propia, pero mi amigo podía verme en su Skype, y además  cuando hacía la prueba de video en el menú opciones de Skype tampoco funcionaba, a pesar de que la webcam en cheese funcionaba sin problemas,  pero la solución era más simple de lo que pensaba, para que primero prueben:

primero cierren skype si lo tienen abierto, luego presionen alt+f2 y pongan
export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
y les funcionará el video.

para no tener que estar a cada rato escribiendo esto, modificamos lo siguiente

sudo gedit /usr/bin/skype-wrapper
buscamos
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
y lo reemplazamos todo por:

export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

y listo guardar y cerrar

Para los que les aparece el skype-wrapper en blanco(que en realidad es porque no existe el archivo) deben hacer lo siguiente:

en la terminal esscriban:


sudo mv /usr/bin/skype /usr/bin/skype2

Luego en la misma terminal:

sudo gedit /usr/bin/skype

ahi copian y pegan la siguiente linea:


#!/bin/bash
export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype2

guardan y cierran el archivo

Si por alguna razón no les ejecuta, prueben a cambiar los permisos sudo chmod 777 /usr/bin/skype

26 comentarios:

  1. Me pasaba lo mismo, pero con Omegle en Firefox, usando el mismo comando, cambiando 'skype' por 'firefox' se soluciona el problema también.
    Saludos :D

    ResponderEliminar
  2. Funcionó perfecto para mí, gracias por el dato.
    Ubuntu 10.04, Dell Inspiron 11z

    ResponderEliminar
  3. muchas gracias me funciono!
    probado en debian squeeze, webcam datavision dtwc-150 y skype 2.1.0.81

    ResponderEliminar
  4. arregle el problema del video pero ahora no puedo transmitir por el microfono =(

    ResponderEliminar
  5. hugo puede ser una mala configuracion del pulseaudio

    ResponderEliminar
  6. cuando intento meterme al gedit, me sale una ventana de gedit pero en blanco, no sale nada, que debo hacer?
    gracias

    ResponderEliminar
  7. Puede ser porque no exista skype-wraper, sino que existe solamente skype, con la ultima actualizacion quedo así, aún tienes el problema de video?

    ResponderEliminar
  8. YO CERRE SKYPE, PERO CUANDO PRSIONO alt+f2 NO HACE NADA.

    ResponderEliminar
  9. es porque tienes deshabilitado el ejecutar, prueba abriendo una terminal

    ResponderEliminar
  10. Cuando hice lo que dijiste el video funcionó barbaro, pero despues me paso lo mismo que el pollo, skype-wrapper esta en blanco, despues usando skype normal no me anda, que hago??

    ResponderEliminar
  11. actualicé el post poniendo la solución para lo tuyo, recuerda respetar los espacios al usar el mv

    ResponderEliminar
  12. perfecto dansanti, solo una cosa donde pones sudo mv /usr/bin/skype /usr/bin skype2, faltó una / entre bin y skype2, por lo menos asi me funciono a mi

    ResponderEliminar
  13. dansanti podes poner denuevo la solución del mv??

    gracias

    ResponderEliminar
  14. ahí esta modificado, no se por qué se eliminó lo que ya había posteado.saludos.

    ResponderEliminar
  15. Gracias, pero evidentemente estoy haciendo algo mal porque despues de hacer eso quiero abrir skype y no se abre.

    ResponderEliminar
  16. dale permisos de ejecucion podria ser asi sudo chmod 777 /usr/bin/skype

    ResponderEliminar
  17. si, después lo pensé, fuincona barbaro, genio!!

    ResponderEliminar
  18. muchas gracias por este post!!! funcionando la webcam del skype desde un xubuntu!!!

    ResponderEliminar
  19. no puedo abrir el skype ahora locooooo

    ResponderEliminar
  20. Me han sacado de una desesperacion increible, ahora tengo mi video sin ningun problema, pero hay algo en el post, el ultimo paso seria dar los permisos a skype, edita el post y pon el comando para que las personas lo coloquen sin estar leyendo los comentarios, asi se les sera mas facil! Saludo a todos y muchusimas gracias!

    ResponderEliminar
    Respuestas
    1. me alegra, modificaré el post principal, se me había olvidado.. saludos

      Eliminar
  21. Graaaciiiiiaaaaaaaaaaassss! le Solucionaron ese problema a mi amigo Alìí Figuera Apl. pero lo que dice es cierto lo unico que le falto al post fue ese comando que publico dansanti (sudo chmod 777 /usr/bin/skype) sin los parentesis claro. Bueno sin mas que decir me Despido y Muchaas GRAACIIIAAAS de verdad :D

    ResponderEliminar